LED Bulb Replacement - IT WORKS!

  1. JOKER8R

    JOKER8R Well-Known Member

    First Name:
    Joe
    Vehicle(s):
    2020 JTR / GCM - 2016 KIA Optima
    Joined:
    Jul 19, 2019
    Location:
    Indiana
    Posts:
    195
    Liked:
    269
    The ones that @mikesjt used when he started the thread
     
  2. Jellygladiator

    Jellygladiator Well-Known Member

    First Name:
    James
    Vehicle(s):
    gladiator
    Joined:
    Jun 22, 2019
    Location:
    Kentucky
    Posts:
    126
    Liked:
    61
    Occupation:
    retired
    Rgr
     
  3. JOKER8R

    JOKER8R Well-Known Member

    First Name:
    Joe
    Vehicle(s):
    2020 JTR / GCM - 2016 KIA Optima
    Joined:
    Jul 19, 2019
    Location:
    Indiana
    Posts:
    195
    Liked:
    269
    ?
     
  4. Digger70

    Digger70 Well-Known Member

    Vehicle(s):
    2020 Rubicon Gladiator Firecracker Red 8/22/19, 2019 Sahara JLU Hella Yella 6/5/19, 2015 Sahara JK Baja Yellow 3/17-6/19, 2014 Flame Red Willys Wheeler JK 6/14-3/17
    Joined:
    Jun 14, 2019
    Location:
    Clearfield County, PA
    Posts:
    103
    Liked:
    121
    I bought some Beamtech H13 LED bulbs https://www.amazon.com/gp/product/B073ZDLKT9/ref=ask_ql_qh_dp_hza and tried to install them today and the plugs don't match up. On my stock headlight the stock bulb's wire hooks to the inside of the headlight and on the outside it's a square plug. The LED bulb has a rectangular plug with rounded ends. How do I unhook the stock bulb? It looks like I'd have to take apart the the whole headlight to remove the stock bulb's plug.
     
  5. JOKER8R

    JOKER8R Well-Known Member

    First Name:
    Joe
    Vehicle(s):
    2020 JTR / GCM - 2016 KIA Optima
    Joined:
    Jul 19, 2019
    Location:
    Indiana
    Posts:
    195
    Liked:
    269
    I removed the grill then removed the headlight assembly. After that unscrew the big plug seal on back to access the wires and unplug them. Is this what you were asking?
     
  6. Digger70

    Digger70 Well-Known Member

    Vehicle(s):
    2020 Rubicon Gladiator Firecracker Red 8/22/19, 2019 Sahara JLU Hella Yella 6/5/19, 2015 Sahara JK Baja Yellow 3/17-6/19, 2014 Flame Red Willys Wheeler JK 6/14-3/17
    Joined:
    Jun 14, 2019
    Location:
    Clearfield County, PA
    Posts:
    103
    Liked:
    121
    I did that. When I unplug the stock bulb the wire for it goes down inside the headlight assembly and connects to that square-ish plug. So I can't remove the stock halogen bulb unless I take apart the whole headlight assembly. I should have taken pics haha
     
  7. JOKER8R

    JOKER8R Well-Known Member

    First Name:
    Joe
    Vehicle(s):
    2020 JTR / GCM - 2016 KIA Optima
    Joined:
    Jul 19, 2019
    Location:
    Indiana
    Posts:
    195
    Liked:
    269
    On mine, when I unplug the bulb the LED bulb wire plugs into that connection. Weird, not sure about yours
     
  8. Digger70

    Digger70 Well-Known Member

    Vehicle(s):
    2020 Rubicon Gladiator Firecracker Red 8/22/19, 2019 Sahara JLU Hella Yella 6/5/19, 2015 Sahara JK Baja Yellow 3/17-6/19, 2014 Flame Red Willys Wheeler JK 6/14-3/17
    Joined:
    Jun 14, 2019
    Location:
    Clearfield County, PA
    Posts:
    103
    Liked:
    121
    It's weird. I've put LED bulbs in my previous Wranglers and they had an adapter to go from the standard halogen plug to the LED. It was so odd that I took off the headlight and cap and removed the halogen bulb but the wire for the bulb goes down inside the headlight and I'd have to have babydoll hands to reach down and try to unplug it. At this point I'd plug in the LED bulb and have to get an adapter so I can plug the wire into the plug that comes from the Jeep but the existing halogen plug would have to just dangle from the back of the headlight. I'm not sure if I can remove the plug that attaches to the back of the LED bulb.
     
  9. JOKER8R

    JOKER8R Well-Known Member

    First Name:
    Joe
    Vehicle(s):
    2020 JTR / GCM - 2016 KIA Optima
    Joined:
    Jul 19, 2019
    Location:
    Indiana
    Posts:
    195
    Liked:
    269
    This isn’t my picture but using as reference. When you unplug the back of the oem bulb the wire harness (should) plug right into the led harness. Maybe your LEDs aren’t compatible.

    96D6024E-6FC2-4795-9727-D259D8649440.jpeg
     
  10. Digger70

    Digger70 Well-Known Member

    Vehicle(s):
    2020 Rubicon Gladiator Firecracker Red 8/22/19, 2019 Sahara JLU Hella Yella 6/5/19, 2015 Sahara JK Baja Yellow 3/17-6/19, 2014 Flame Red Willys Wheeler JK 6/14-3/17
    Joined:
    Jun 14, 2019
    Location:
    Clearfield County, PA
    Posts:
    103
    Liked:
    121
    Maybe. I sent a message to the seller this afternoon and am waiting to see what they say. The way my headlights are, on the back bottom of the headlight assembly is a square plug that plugs into the wire coming from the jeep. It won't plug into that kind of plug on the Beamtech LED bulb. Thanks for your help.
     
  11. Digger70

    Digger70 Well-Known Member

    Vehicle(s):
    2020 Rubicon Gladiator Firecracker Red 8/22/19, 2019 Sahara JLU Hella Yella 6/5/19, 2015 Sahara JK Baja Yellow 3/17-6/19, 2014 Flame Red Willys Wheeler JK 6/14-3/17
    Joined:
    Jun 14, 2019
    Location:
    Clearfield County, PA
    Posts:
    103
    Liked:
    121
    I just watched this video ( ) and see what I did wrong. I need to take the plug off the back of the halogen bulb. I knew it had to be something simple haha
     
  12. biggdave92

    biggdave92 Well-Known Member

    Vehicle(s):
    JKR 10A
    Joined:
    Mar 18, 2019
    Location:
    SC
    Posts:
    202
    Liked:
    185
    so i bought these reverse lights. put them in, pull e brake, put in reverse, nothing. it's night here. my 8.4" display is purple. no reverse lights. HELP!!! lol
     
  13. biggdave92

    biggdave92 Well-Known Member

    Vehicle(s):
    JKR 10A
    Joined:
    Mar 18, 2019
    Location:
    SC
    Posts:
    202
    Liked:
    185
    and i put the original bulbs back in, still no reverse lights.
     
  14. biggdave92

    biggdave92 Well-Known Member

    Vehicle(s):
    JKR 10A
    Joined:
    Mar 18, 2019
    Location:
    SC
    Posts:
    202
    Liked:
    185
    ......

    IMG_20191101_194817.jpg
     
    steffen707 likes this.
  15. steffen707

    steffen707 Well-Known Member

    Vehicle(s):
    2001 Jetta TDI RIP, 89' Civic SI, 2019 Pacifica Hybrid, 2020 GLADIATOR SPORT S "GLADYS"
    Joined:
    Jan 28, 2018
    Location:
    Middle Wisconsin
    Posts:
    7,294
    Liked:
    6,885
    well that's weird. Was your door open and nothing worked?

    These cars have auto-park. So if your seatbelt isn't fastened, and the door opens below a certain mph, the car will auto park.

    WARNING, DON'T KILL YOURSELF!

    I plugged seatbelt in, pulled ebrake hard, put in reverse, then opened door.

    If that still doesn't work for you.......i'm at a loss. Do you have a sport/overland or rubicon? you said you've got the 8.4" screen?
     
Loading...

Share This Page