Added MOPAR Aux Switch Pod - The results...

GeepinGeo

New Member
Joined
May 7, 2020
Messages
2
Reaction score
0
Location
PA
Vehicle(s)
JT, JKU, XJ, YJ, JKU
Occupation
Engineer
After watching several videos and reading the directions 10 times, I installed the MOPAR Aux Switch Pod. I do realize you have to have the feature added to your VIN through DealerConnect. What nobody says is what works or doesn't work after the install. Here are my results:

My Front and Rear Cameras no longer worked - "unavailable". OMG, what did I do wrong I thought, after checking fuses and a lost night of sleep, they worked the next morning. Perhaps having the battery disconnected for several hours had an impact.

The Auto Start/Stop Feature no longer works. The Icon displays constant on the dash, the Disable button illuminates and seams to work fine, but the function doesn't work. Could be a blessing, hate it anyways.

Finally, depressing the Switch Pod buttons 1-4 does nothing, they don't illuminate. Not sure if that is the end result before having the vehicle flashed or not. UGH! Time to schedule an appointment.

In the end, they look nice, pain to install, no joke it was frightening ripping the moldling, dash, and fenders apart. Hope it is worth it.



Advertisement


 

Mr._Bill

Well-Known Member
First Name
Bill
Joined
Jul 22, 2019
Messages
663
Reaction score
367
Location
North Las Vegas, NV
Vehicle(s)
2020 Jeep Gladiator Overland 2013 Nissan Leaf SV
Vehicle Showcase
1
After watching several videos and reading the directions 10 times, I installed the MOPAR Aux Switch Pod. I do realize you have to have the feature added to your VIN through DealerConnect. What nobody says is what works or doesn't work after the install. Here are my results:

My Front and Rear Cameras no longer worked - "unavailable". OMG, what did I do wrong I thought, after checking fuses and a lost night of sleep, they worked the next morning. Perhaps having the battery disconnected for several hours had an impact.

The Auto Start/Stop Feature no longer works. The Icon displays constant on the dash, the Disable button illuminates and seams to work fine, but the function doesn't work. Could be a blessing, hate it anyways.

Finally, depressing the Switch Pod buttons 1-4 does nothing, they don't illuminate. Not sure if that is the end result before having the vehicle flashed or not. UGH! Time to schedule an appointment.

In the end, they look nice, pain to install, no joke it was frightening ripping the moldling, dash, and fenders apart. Hope it is worth it.
Check any inline fuses in the AUX switch wiring, and check all related fuses in the box. Others have reported that the instructions have you do things in an order that ends up with popped fuses. If there are any bad fuses, the dealer flash to enable the AUX switches can fail.
 

Kindafearless

Member
First Name
Elise
Joined
Aug 19, 2019
Messages
16
Reaction score
12
Location
Virginia
Vehicle(s)
2020 Jeep Gladiator Rublicon
I added mine this weekend also. Tried using the Superchips programmer to enable them. No dice. The Aux switch option shows up in the UI now, but the switches do nothing. I do have a medium speed CAN bus error code, which I think is good since the switches are a CAN bus device.

Looks like time for a dealer appointment though :/

Has anyone else added the switches through the Superchips programmer?
 

Factoid

Well-Known Member
First Name
Mark
Joined
Dec 2, 2019
Messages
616
Reaction score
856
Location
Atlanta, GA/Mahopac, NY
Vehicle(s)
2020 Gladiator, 2019 Porsche Cayenne S, 1964 Corvette coupe
Occupation
Performance Coach
I swear, I don’t know why these switches aren’t standard. Just chaps my ass.

Best of luck with getting it resolved.
 

Kch

Member
First Name
Kevin
Joined
Jan 5, 2020
Messages
23
Reaction score
19
Location
Louisiana
Vehicle(s)
2020 Jeep Gladiator Rubicon,1932 ford sedan,1932 ford coupe,1931 ford sedan,1959 Olds custom1959 Olds custom
I had the dealer install the switches to my JTR. Nothing will light up until the computer is flashed. There have been many reports of having difficulty getting the computer to flash. The dealer had trouble with mine. Everything would go fine but the switches would not work. The next day they were on line and working. I've read about this delay from other people too. Good luck.
 
OP
GeepinGeo

GeepinGeo

New Member
Joined
May 7, 2020
Messages
2
Reaction score
0
Location
PA
Vehicle(s)
JT, JKU, XJ, YJ, JKU
Occupation
Engineer
  • Thread starter
  • Thread Starter
  • #6
I had the dealer install the switches to my JTR. Nothing will light up until the computer is flashed. There have been many reports of having difficulty getting the computer to flash. The dealer had trouble with mine. Everything would go fine but the switches would not work. The next day they were on line and working. I've read about this delay from other people too. Good luck.
Thanks all for sharing your experience, good to know I'm not the only one.
 

Kindafearless

Member
First Name
Elise
Joined
Aug 19, 2019
Messages
16
Reaction score
12
Location
Virginia
Vehicle(s)
2020 Jeep Gladiator Rublicon
Have an appointment with the dealer tomorrow to activate! Will report back :)
 

teleportJeep

Well-Known Member
First Name
Marco
Joined
Mar 31, 2020
Messages
46
Reaction score
67
Location
San Diego
Vehicle(s)
gladiator
I installed the AUX switches over the weekend.
Biggest issues:
The zip ties are too short and hard to wrap them around.
I couldn’t figure out initially that you need to poke a hole in the rubber to get the cables inside.
I didn’t have the tool to take out the orange cable pin - I used 2 thick needles and lots of patience.
The Uconnect system went into default mode and disable many features due to disconnecting the batteries. After a few hours Uconnect rebooted and everything came back.
Used JSCAN to enable AUX switches. They now work fine andsee the aux options in the Uconnect.
I did not connect the battery until the very end.
 

Kindafearless

Member
First Name
Elise
Joined
Aug 19, 2019
Messages
16
Reaction score
12
Location
Virginia
Vehicle(s)
2020 Jeep Gladiator Rublicon
Got the truck back from the dealer. charged me $80 and they managed to regress the installation.... I told the service guy that there isn’t an aux switches entry in the settings page anymore and the lights weren’t turning on. Their response: “it won’t turn on until I plug an accessory into it. Add an accessory and if it doesn’t work come back.”

I just turned around and left. I hate liars.

Ordered a JSCAN plug before I left the parking lot.
 
Last edited:

Bonanza

Member
Joined
Apr 22, 2020
Messages
15
Reaction score
7
Location
Southern CA
Vehicle(s)
Sport S Max Tow Punk'n
For all people who will search this issue:

The switches will not turn on without a flash. I used a superchips programmer, no dealer, and from there the backlight turned on, the indicator led turned orange, and the Uconnect had the options for it.
I blew the inline fuse during my install. Replaced it thinking it would turn them on, nope. Needs the flash. Going through the firewall is insanely difficult. I wish Jeep engineered an auxiliary grommet. This was the hardest wiring routing I’ve ever done. Making matters worse, I routed it wrong through the engine bay so I had to pull it all out and do it again!! Be wary— there is almost no extra wire length so get the route correct!

I used a thin punch to loose the harness wires. I soldered the orange wires, no need to pin the harnesses.
 

Factoid

Well-Known Member
First Name
Mark
Joined
Dec 2, 2019
Messages
616
Reaction score
856
Location
Atlanta, GA/Mahopac, NY
Vehicle(s)
2020 Gladiator, 2019 Porsche Cayenne S, 1964 Corvette coupe
Occupation
Performance Coach
Yeah, the relays are configured and controlled by the computer, not the switches. Without the flash, the computer will not link the switches to the relays. No relay, no light, no control.
 

Indavis01

Well-Known Member
First Name
Tim
Joined
Apr 7, 2020
Messages
101
Reaction score
84
Location
Houston, Texas
Vehicle(s)
2020 Gladiator Overland, 2016 Volvo Xc90 Polestar
Occupation
Finder of bad stuff and people.
Vehicle Showcase
1
Got the truck back from the dealer. charged me $80 and they managed to regress the installation.... I told the service guy that there isn’t an aux switches entry in the settings page anymore and the lights weren’t turning on. Their response: “it won’t turn on until I plug an accessory into it. Add an accessory and if it doesn’t work come back.”

I just turned around and left. I hate liars.

Ordered a JSCAN plug before I left the parking lot.
Man, thats really disappointing. I ordered the JSCAN as well- can't go wrong for the 70-80 bucks. I have a feeling it will be more necessary as the truck gets more modded.
 

Kindafearless

Member
First Name
Elise
Joined
Aug 19, 2019
Messages
16
Reaction score
12
Location
Virginia
Vehicle(s)
2020 Jeep Gladiator Rublicon
Man, thats really disappointing. I ordered the JSCAN as well- can't go wrong for the 70-80 bucks. I have a feeling it will be more necessary as the truck gets more modded.
Don’t forget to get the security bypass if your plug doesn’t come with it. I got my MX+ in and quickly realized I was missing the cable.
 

Kindafearless

Member
First Name
Elise
Joined
Aug 19, 2019
Messages
16
Reaction score
12
Location
Virginia
Vehicle(s)
2020 Jeep Gladiator Rublicon
I installed the AUX switches over the weekend.
Biggest issues:
The zip ties are too short and hard to wrap them around.
I couldn’t figure out initially that you need to poke a hole in the rubber to get the cables inside.
I didn’t have the tool to take out the orange cable pin - I used 2 thick needles and lots of patience.
The Uconnect system went into default mode and disable many features due to disconnecting the batteries. After a few hours Uconnect rebooted and everything came back.
Used JSCAN to enable AUX switches. They now work fine andsee the aux options in the Uconnect.
I did not connect the battery until the very end.
There are three auxiliary switch settings groups in JScan, I set each of them to what seemed to make sense, eg: 4 switch. Did you change all of those settings too?
 

                           
























































Top